VDV Startup Guide

Evaluation

It is our purpose to help you Evaluating Vista Data Vision Successfully. Contact us to get trial version of Vista Data Vision. You can get fully functional 90 day Evaluation Version with with tool kits. We offer three versions of VDV: Standard, Professional and Enterprise. We can prepare Evaluation version suited to your needs and will help you with the initial configurations if needed.

VDV Startup Guide

This is an simple startup guide for Vista Data Vision. Here below we go through the basic functions and configurations after VDV installation

Need Help?

Vista Data Vision has a powerful Help File for each Application. In the Menu bar you will find the Help in each application (db.robot, db.data.browser and db.webbrowser). When configuring VDV you will find the Help Icon at the bottom. Clicking this icon will open the Help File for that Item. If you have some questions or problems please feel free to contact us.

 

01 How Vista Data Vision works


When starting VDV always start by running db.robot.c which will also start the MySQL database.

Vista Data Vision (VDV) consists of three applications. These applications are db.robot.c, db.data.browser and db.web.browser.

db.robot.c is a database application, specially made to copy data automatically from .DAT text data files into MySQL database as well as to build all associated tables and to do all book keeping of relations and tags. Also, db.robot.c handles Alarm service, Reports, Validation and other services. Db.robot.c utilizes advanced methods for database maintenance, import of modified data and will cope with changing data structure of .DAT files and relocation.

db.robot.c constantly monitors data files retrieved by Data Collection Application and copy all new data into its database without delay. User can give each and every variable a new descriptive name and associate each variable with a unit for calculations and reports. Also, db.robot.c will allow users to import older data kept in data files and to import modified data in order to add or overwrite data in database with the modified values. Once data is in the database, it can be accessed using db.data.browser and db.web.browser. Experienced users can use SQL commands to read data directly from the database into other applications.

db.data.browser is a general and flexible data browser, where user can build display pages with up to 6 graphs and incorporate up to 50 variables into each graph. Therefore, a single page can display everything from a single graph with a single variable up to 6 graphs with 50 variables each, or 300 variables total. The graphs can include any variable from any location. Using innovative command buttons, user can easily travel through time and choose any length of period for display.

db.web.browser is a database web browser, allowing web users to do most of the work handled by db.data.browser through web interface and much more. This application includes everything needed to start web service. Its displays can be configured in any language like English, German and Spanish. Users outside the local network can access the data, as soon as the web server is published to the world wide web. An easy way to start web access to VDV is to use the IIS (Internet Information Server) web server which is built into most of Microsoft’s operating systems. Service providers will use the build-in access control to give access to the data, so each user will only have access to the his data and not to data belonging to others.

02 Register, Import and Graph the data


You have successfully installed Vista Data Vision. Here are some useful instructions and tricks on how to get started using Vista Data Vision. If you have any questions or problems during the configurations of VDV please feel free to contact us.
400x400

02.1 Register the software


After the install it is necessary to register db.robot, db.data.browser and db.web.browser. To do so go to Help > Register Product on each application and put in User, Company and Product key.

Register

Note: If there is no internet connection select phone activation and send the authorization codes to Vista and get back activation codes to register and activate each application.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

02.2 Import the sensor Data File


In this chapter we are going to import our sensor data file and create few Graphs. If you have data from other datalogger then Campbell SCI you need to take close look at step number 2 regarding the VDV File Converter.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

02.2.1 Open db.robot.c (c:/Vista Data Vision/db.robot.c/db.robot.c.exe)


Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

02.2.2 VDV File Converter | If you have data file not from Campbell SCI dataloggers


The VDV File Converter opens doors to import data from almost any source storing data in delimited text file. This includes data from most data logging systems, data from spreadsheet origin and data found in manually maintained data sheets. The VDV File Converter also supports data forwarded from remote dataloggers via FTP transmissions.

VDV File Converter will continuously monitor the selected data files and convert new data to a vdv compatible file.

The VDV File Converter allows you to convert both a single data file or a folder of incremental data files (commonly found when data loggers use ftp to send data).

See a Video here on how VDV File Converter works (This video is not from the newest version but it shows the basic functions).

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

02.2.3 If you have a Campbell SCI .dat file add the file


Go to Edit menu and click Add Site. Locate the File, name it and click next.

import-addsite1

Click Select File and locate your .dat file. Give the new Site a Name and an Owner. With Owner you can filter your data files later.

Click Next

import-addsite2

Here is a list of all parameters in the Data File. If needed give each parameter a Alias Name.

Click the Select button to select a unit for each parameter. If you have many parameters with the same unit click Select Units Quickly at the bottom. There you can select multiple parameters by holding down ctrl button or using shift.

Click Next.

import-addsite3

Finally we have an overview for the Station we are about to import. Review the configuration and click Finish

Click Next.

import-addsite4

 

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

02.2.4 Real time graphs


Open db.data.browser (C:/Vista Data Vision/db.data.browser/db.data.browser.exe)

Note: Enterprise version has Page setup in the web interface also

Go to Edit menu and click Page Setup. Locate the File, name it and click next.

import-graph1

In Vista Data Vision data is categorized into Sites and Pages where each Site can contain many pages.

Locate the Site we just Imported, Click New Page and name your Page. Finally Click New Graph.

import-graph2

Name your Graph and double click on the Variable you want to add to the Graph or use the Arrows.

There are a lot of configurations that can be done on each Graph, here is an example of what we did.

In Variable Setup tab we changed the Color of the Line and the Width to 3

In Y-Axis:Left we set the Scale To Manual and set Lower Limit to 0 and Upper Limit to 360 so our Wind Direction Graph will always have a fixed Axis.

Go to the Help file to read about each configuration.
Help menu » Help. In the Help File open
Page Setup » Graphs

Click Save.

Create couple real time graphs and Click View » Graphs 

import-graph3

On the Left hand side select our Site and Our new Graphs will show up.

  • Click on the Graph to Enlarge it.
  • Change the Scale at the top
  • Scroll Back and Forth in the data (arrows right next to the Scale).

import-graph4-1

 

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

03 IIS Configuration


Internet Information Services (IIS) is an extensible web server created by Microsoft for use with Windows. IIS is not turned on by default when Windows is installed. The IIS Manager is accessed through the Microsoft Management Console or Administrative Tools in the Control Panel. Following are step-by-step instructions on how to configure the IIS for Windows Server 2012, Windows 8 and Windows 7. These instructions are very much alike and could also apply to older Windows servers but the outlook could be little different between versions.

iis7

03.1 IIS Configuration – Windows Server 2012


These instructions are for configuration of the IIS (Internet Information Service) Web Service for Windows Server 2012 so it will work with the web service of VDV. IIS is built into Microsoft operating system. By following these step-by-step instructions the IIS should be operational to provide web service for VDV

In order to install IIS, open Control Panel and select Programs and click Turn Windows features on or off.

Server2012pic1

Click on Next until Server Roles comes and then check Web Server (IIS) from the list.

Server2012pic6

After having added Web Server (IIS) make sure to locate Aplication Development and check CGI, ISAPI Extensions and ISAPI Filters. Install the features and the IIS services should be ready for configurations (it could be necessary to restart the server at this point).

Next open Control Panel > System and Security > Administrative Tools > Internet Information Services (IIS) Manager.

Server2012pic12

Next right click on the Default Web Site and click Add Virtual Directory.

Server2012pic13

Enter vdv as Alias and browse to the vdv_www folder (default location is C:\Vista Data Vision\db.web.browser\vdv_www). Press OK to finish.

Next select the new vdv virtual directory and double click on Handler Mappings.

Server2012pic14

Click on Add Module Mapping… in the top right corner.

Server2012pic15

When selecting the Executable (optional): make sure that you select (*.exe) in the bottom right corner and php-cgi (default location is C:\Vista Data Vision\db.web.browser\PHP\php-cgi.exe).

Server2012pic17

Select FastCgiModule from the Module Drop down list. It may be necessary to type ” around the Executable path.  Enter PHP for Name. Press OK to finish.

Server2012pic18

Click Yes to allow PHP.

Server2012pic19

Next select the top node in the Connections list (the server name).

Server2012pic20

Double click on ISAPI and CGI Restrictions.

Server2012pic20

If php.exe has not been added to the list then it needs to be added manually. For adding PHP manually click Add… in the top right corner.

Server2012pic21

Browse to php-cgi.exe for ISAPI or CGI path (default location is C:\VistaData Vision\db.web.browser\PHP\php-cgi.exe). Remember to select (*.exe) in the bottom right corner when locating php-cgi.exe  If php-cgi.exe cannot be seen then select exe from the File Type dropdown list. It may be necessary to type ” around the Executable path. Enter PHP for Description. Check Allow extension path to execute. Press OK to finish.

When the system has been installed and db.robot.c is running, open a web browser on the server and type http://localhost/vdv in the address field. You should see the VDV standard website if you have VDV Standard or if you have not registered. For registered VDV Professional or Enterprise version a Login page is shown.

Configure the php.ini file

If Vista Data Vision is not installed directly under C:\ then one change must be made to the php.ini file located under /Vista Data Vision/db.web.browser/php5.2

Find these lines

session.save_path = C:\Vista Data Vision\db.web.browser\php5.2\sessiondata
upload_tmp_dir = “C:\Vista Data Vision\db.web.browser\php5.2\upload_temp”

Change it to the path where you have installed VDV. For example if VDV is installed on the D drive you would change the line to:

session.save_path = D:\Vista Data Vision\db.web.browser\php5.2\sessiondata
upload_tmp_dir = “D:\Vista Data Vision\db.web.browser\php5.2\upload_temp”

 

Test the Web

Note: If you want to see if PHP has been installed correctly create an info.php file and store it in \Vista Data Vision\db.web.browser\vdv_www folder. info.php file is just a text file and may be created using Notepad. The file should only contain the following php code.

<?php
phpinfo()
?>

Open a Web Browser and type in http://localhost/vdv/info.php. You should see an information page on PHP. If you do not see this page, check that you have performed the steps above correctly.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

03.2 IIS Configuration – Windows 8


These instructions are for configuration of the IIS (Internet Information Service) Web Service for Windows 8 so it will work with the web service of VDV. IIS is built into Microsoft operating system. By following these step-by-step instructions the IIS should be operational to provide web service for VDV

In order to install IIS, open Control Panel and select Programs and Features and click Turn Windows features on or off.

Win8pic1

Locate and check Internet Information Services. Expand World Wide Web Services and then expand Application Development Features, check CGI, ISAPI Extensions and ISAPI Filters.

Win8pic2

Now IIS has been configured to work with PHP.

Next step is to add VDV to IIS.

Open Control Panel > System and Security > Administrative Tools, locate and open Internet Information Services (IIS) Manager.

Win8pic3

Next right click on the Default Web Site and click Add Virtual Directory.

Win8pic4

Enter vdv as Alias and browse to the vdv_www folder (default location is C:\Vista Data Vision\db.web.browser\vdv_www). Press OK to finish.

Win8pic5

Next select the new vdv virtual directory and double click on Handler Mappings.

Win8pic6

Click on Add Module Mapping… in the top right corner.

Win8pic7

When selecting the Executable (optional): make sure that you select (*.exe) in the bottom right corner and php-cgi (default location is C:\Vista Data Vision\db.web.browser\PHP\php-cgi.exe).

Win8pic8

Select FastCgiModule from the Module Drop down list. It may be necessary to type ” around the Executable path.  Enter PHP for Name. Press OK to finish.

Win8pic9

Click Yes to allow PHP.

Win8pic10

Next select the top node in the Connections list (the server name) and double click on ISAPI and CGI Restrictions.

Win8pic11

If php.exe has not been added to the list then it needs to be added manually. For adding PHP manually click Add… in the top right corner.

Win8pic12

Browse to php-cgi.exe for ISAPI or CGI path (default location is C:\VistaData Vision\db.web.browser\PHP\php-cgi.exe). Remember to select (*.exe) in the bottom right corner when locating php-cgi.exe  If php-cgi.exe cannot be seen then select exe from the File Type dropdown list. It may be necessary to type ” around the Executable path. Enter PHP for Description. Check Allow extension path to execute. Press OK to finish.

Win8pic13

When the system has been installed and db.robot.c is running, open a web browser on the server and type http://localhost/vdv in the address field. You should see the VDV standard website if you have VDV Standard or if you have not registered. For registered VDV Professional or Enterprise version a Login page is shown.

Configure the php.ini file

If Vista Data Vision is not installed directly under C:\ then one change must be made to the php.ini file located under /Vista Data Vision/db.web.browser/php5.2

Find these lines

session.save_path = C:\Vista Data Vision\db.web.browser\php5.2\sessiondata
upload_tmp_dir = “C:\Vista Data Vision\db.web.browser\php5.2\upload_temp”

Change it to the path where you have installed VDV. For example if VDV is installed on the D drive you would change the line to:

session.save_path = D:\Vista Data Vision\db.web.browser\php5.2\sessiondata
upload_tmp_dir = “D:\Vista Data Vision\db.web.browser\php5.2\upload_temp”

Test the Web

Note: If you want to see if PHP has been installed correctly create an info.php file and store it in \Vista Data Vision\db.web.browser\vdv_www folder. info.php file is just a text file and may be created using Notepad. The file should only contain the following php code.

<?php
phpinfo()
?>

Open a Web Browser and type in http://localhost/vdv/info.php. You should see an information page on PHP. If you do not see this page, check that you have performed the steps above correctly.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

03.3 IIS Configuration – Windows 7


These instructions are for configuration of the IIS (Internet Information Service) Web Service for Windows 7 so it will work with the web service of VDV. IIS is built into Microsoft operating system. By following these step-by-step instructions the IIS should be operational to provide web service for VDV

In order to install IIS, open Control Panel > Programs and Features and click Turn Windows features on or off in the top left corner.

Win7pic1

 

Locate and check Internet Information Services. Expand World Wide Web Services and then expand Application Development Features, check CGIISAPI Extensions and ISAPI Filters.

Win7pic2

Now IIS has been configured to work with PHP.

Next step is to add VDV to IIS.

Open Control Panel > System and Security > Administrative Tools, locate and open Internet Information Services (IIS) Manager.

Win7pic3

Next right click on the Default Web Site and click Add Virtual Directory.

Win7pic4

Enter vdv as Alias and browse to the vdv_www folder (default location is C:\Vista Data Vision\db.web.browser\vdv_www). Press OK to finish.

Win7pic5

Click on Add Module Mapping… in the top right corner.

Win7pic7

When selecting the Executable (optional): make sure that you select (*.exe) in the bottom right corner and php-cgi (default location is C:\Vista Data Vision\db.web.browser\PHP\php-cgi.exe).

Win7pic8

Select FastCgiModule from the Module Drop down list. It may be necessary to type ” around the Executable path.  Enter PHP for Name. Press OK to finish.

Win7pic9

Click Yes to allow PHP.

Next select the top node in the Connections list (the server name) and double click on ISAPI and CGI Restrictions.

Win7pic10

If php.exe has not been added to the list then it needs to be added manually. For adding PHP manually click Add… in the top right corner.

Win7pic11

Browse to php-cgi.exe for ISAPI or CGI path (default location is C:\VistaData Vision\db.web.browser\PHP\php-cgi.exe). Remember to select (*.exe) in the bottom right corner when locating php-cgi.exe  If php-cgi.exe cannot be seen then select exe from the File Type dropdown list. It may be necessary to type ” around the Executable path. Enter PHP for Description. Check Allow extension path to execute. Press  to finish.

Win7pic13

When the system has been installed and db.robot.c is running, open a web browser on the server and type http://localhost/vdv in the address field. You should see the VDV standard website if you have VDV Standard or if you have not registered. For registered VDV Professional or Enterprise version a Login page is shown.

Configure MIME Types

VDV2013 uses the html5 <audio> tag to play alarm sounds. To have the Alarm sound played in browsers the .OGG file Extension needs to be allowed. OGG is a file format supported by all browsers.

This change requires a manual change to IIS to make it support ogg.

Win7pic14

In the IIS configuration click MIME type. Search for .ogg extension in the list. If it is not in the list click Add in the top-right corner. If it exists there is no need to add it and the next steps may be skipped.

Win7pic15

Click Add

Win7pic16

Use the following information and click ok.
File name extension: .ogg
MIME type: audio/ogg

Configure the php.ini file

If Vista Data Vision is not installed directly under C:\ then one change must be made to the php.ini file located under /Vista Data Vision/db.web.browser/php5.2

Find these lines

session.save_path = C:\Vista Data Vision\db.web.browser\php5.2\sessiondata
upload_tmp_dir = “C:\Vista Data Vision\db.web.browser\php5.2\upload_temp”

Change it to the path where you have installed VDV. For example if VDV is installed on the D drive you would change the line to:

session.save_path = D:\Vista Data Vision\db.web.browser\php5.2\sessiondata
upload_tmp_dir = “D:\Vista Data Vision\db.web.browser\php5.2\upload_temp”

Test the Web

Note: If you want to see if PHP has been installed correctly create an info.php file and store it in \Vista Data Vision\db.web.browser\vdv_www folder. info.php file is just a text file and may be created using Notepad. The file should only contain the following php code.

<?php
phpinfo()
?>

Open a Web Browser and type in http://localhost/vdv/info.php. You should see an information page on PHP. If you do not see this page, check that you have performed the steps above correctly.

 

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

04 Basic Configurations


In this Chapter we are going to point out how and where to do most of VDV Configurations. We will not go into any details however in the Help File there are a detailed instructions on each item.

04.1 Web Server


After the IIS Configurations here above it is possible to access VDV through the internet browser. To be able to view the VDV web on the internet the server/computer running IIS must have a fixed IP address that is open to the internet. Contact your system administrator or your Internet Service Provider for information on how to acquire a fixed IP address and how to configure the computer and firewall to be able to access the VDV web interface on the internet. If there is not a fixed IP address on the server/computer port 80 can be opened and then it is possible to access VDV through the LAN (Local Area Network) by writing the server/computer IP number/vdv in the address bar on the internet browser.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

04.2 Mail Server


Before VDV can send out emails you need to Configure your Mail Server. This is done in db.robot.c under Edit menu Mail Server Setup.

Click the Help Icon at the bottom to read in more detail how to configure the Mail Server.

config-mailserver

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

04.3 Alarms


Alarms in VDV are a very powerful feature that will simplify the operation of a network of dataloggers. Alarms have twofold purpose:

  • VDV will monitor all new data entered into the datatbase and send out alarms as email and/or SMS Text Message if a value of a variable cross pre-defined limits.
  • VDV will send out an Alarm if data is not being updated on a regular basis. E.g. VDV will send out an Alarm if no new data has arrived for the last 6 hours indicating some communication error between the station and server.

Alarms are configured in db.robot.c under Edit menu » Alarm Site Setup

Data Update Monitoring is configured in db.robot.c under Edit menu » Data Update Monitor.

Read the Help File for more Information on how to configure the Alarms (Help File » Toolkits » Alarm Toolkit)

config-alarms

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

04.4 Reports


The Report Toolkit allows users to create Report summaries. Select variables to include in the Report and generate it automatically and sent to a group of contacts. The Reports can be generated as a delimited text file document or as a Microsoft Word document.

Open db.robot.c and navigate to Edit> Sumamry Report Setup and create a new report.

Depending on your toolkits you will see different options at the bottom of Edit menu in db.robot.c.

Read the Help File for more Information on how to configure the Reports (Help File » Toolkits » Report Toolkit)

config-reports

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05 Useful things to look at after basic configuration


05.1 Create a new user


This feature is only for Professional and License above. If you are running a Trial Version and would like to try out the Professional or Enterprise Version please contact us for an Evaluation License.

You may create unlimited number of users and give them access to specific data and functions.

Take a look at this video to see how it works. (This is a video from older version but it shows basic functions well)

To Create a New User, Edit or Delete an Existing one, select Access Control – User Setup from the Edit menu.

Win7pic1

Note: This feature is also available in Enterprise Version under Configuration>User Setup in the web interface.

Win7pic1

Highlight the user to Delete or Edit and click corresponding button. Click New User to create a new one.

Win7pic1

Fill out the User Name, Full Name, Password and Re-Enter Password. Note that the User Name and Password must be at least 4 letters.
Select a User Logo for the user.
Select a Owner for the User. The Owner property is used to group users together. A User can only Edit and Delete Users over the Web who have the same Owner as he.
Select a Contact Group for the User. The Owner property is used to group contacts together. A User can only Edit and Delete Contacts over the Web who have the same Contact Group as he.
Select a Language for the user. The user will view the VDV web in the Language selected.
Enter a Description for the user.

Next Select the Sites you wish the User to have access to. If the User should always have access to all Sites, even when new Sites are added later, then check the All Sites box.

Next Select the Functions you wish the User to have access to.

Win7pic1

  • Display Welcome Page If unchecked then the user is taken directly to the first Page on login rather then the Welcome Page.

Functions

  • Save Data Allows the User to Save data to his computer.
  • View Table Allows the User to view data as numeric values in a table.
  • Scroll Data Allows the User to Scroll to view older data. The default view only displays the latest 2 days of data, if the user does not have access to Scroll Data then he can only view those 2 days.
  • Auto Refresh Allows the User to automatically refresh the data in the web browser, thus always displaying the latest data.
  • Page Info Allows the User to view Page Information.
  • View Log Allows the User to View the Log messages for Sites he has access to.
  • XY Graph Allows the User to view the XY Graph.
  • Windrose Allows the User to view the Windrose.
  • Distribution Wind Rose Allows the User to view the Distribution Windrose.
  • Filter Wind Rose Allows the User to view the Filter Wind Rose.
  • Histogram Allows the User to view the Histogram Graph.
  • Sort by Size Allows the User to view the Size Graph.
  • Overlay Graph Allows the User to view the Overlay Graph.
  • Intensity Plot Allows the User to View the Intensity Plot.

Real Time Displays

  • Real Time Display Gives the user access to view Real Time Displays.
  • Active Links Gives the User access to click RTD Links.
  • All Displays Gives the User access to all RTD even if new Maps are added later.

If the User does not have access to All Displays click Select RTD and choose the maps the user is to have access to.

Win7pic1

Webcam

  • Webcam Allows the User to view webcam.
  • Comments Allows the User to add a comment to webcam pictures.

Notes

  • View Type: There are 4 types of access that can be given to a User. No Access, the User cannot view Notes. View, the User can only View Notes. Edit, the User can view Notes and also create new Notes and Edit notes that he has created. Admin, the User can view Notes and create new Notes, he can also Edit all Notes.

Notes Type Allows the User to create new Note Types and edit existing Note Types.

Advanced

  • Wind Energy Allows the User to view the Wind Energy Control.
  • Displacement Graph Allows the User to view Displacement Graph. Access to Displacement Graphs is linked to Owner. The User can view all Displacement Graphs that have the same Owner as the User.
  • Manual Collect Allows the User to start a Manual Collection of data through LoggerNET for Sites he has access to
  • Gmap Allows user to access the Google Map view. User can see all sites that he has access to and are configured to show on the Map.
  • Gmap Site Setup Allows users to configure Sites to show on the Map.
  • Site Setup Allows user to change Site Setup online similar as in db.robot.c. User can change Site name, toggle Site Active status, change its owner, change Variable alias and Variable Units.
  • Validation Setup Allows user to configure Validation like in db.robot.c.

Users

  • New User Allows the User to create new Users. It is not possible to give a new User more rights then the current User has.
  • Edit User Allows the User to Edit users. If the User is connected to a Owner then he can only Edit those users who are also connected to that same Owner.
  • Delete User Allows the User to Delete users. If the User is connected to a Owner then he can only Delete those users who are also connected to that same Owner.

Contacts

  • Contact Setup Allows the User to create, edit and delete Contacts and Contact Groups. If the user has access to only one Contact Group then he only has access to contacts in that Contact Group.

Notice: The Contact function is only visible if the Alarm Toolkit or the Report Toolkit has been purchased.

Alarms

  • Alarm Overview Allows the User to see a list of Active Alarms
  • Alarm Setup Allows the User to alter the Alarm Setup for Sites he has access to.
  • Alarm Confirm Allows the User to Confirm Alarms belonging to Sites he has access to.
  • Data Overview Allows the User to see a list of Sites he has access to and the last update time for those sites.

Notice: The Alarm functions are only visible if the Alarm Toolkit has been purchased.

Manual Input

  • New Records Allows the user access to add new Records to Sites that he has access to and have been configured to allow Manual Input.
  • Edit Values Allows the user access to edit values for Sites that he has access to and have been configured to allow Manual Input.
  • Delete Records Allows the user access to delete Records for Sites that he has access to and have been configured to allow Manual Input.

Notice: For Manual Input the User must have access to the Manual Input function and also the Site must be configured to allow Manual Input. Sites are configured for Manual Input in db.robot.c, please refer to the help file for db.robot.c for more information.

Documents

  • View Type: There are 4 types of access that can be given to a User. No Access, the User cannot view Documents. View, the User can only View Documents. Edit, the User can view Documents and also create new Notes and Edit Documents that he has created. Admin, the User can view Documents and create new Documents , he can also Edit/Delete all Documents.

NOTE: User will see all Documents that are connected to the same Owner that he is connected to as well all Documents that are connected to Sites that he has access to.

Press the Create User button when done.

Win7pic1

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.2 Virtual Variables


Virtual Variables are used to create new calculated variables that are a mathematical function of one or more measured variables. Virtual Variables are useful to rescale as well as to calculate results that were not calculated in the datalogger. Easily create an equation using variables from different Sites(dataloggers).

You can add Virtual Variables to Graphs and in Reports and Monitor them for Alarms.

useful-vv

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.2.1 New Virtual Variable


NOTE: This feature is not available in the Base version of db.data.browser.

To view Virtual Variables, select Virtual Variable from the Edit menu.

General

Win7pic1

The Site list and Virtual Variable list contains already created Virtual Variables that have been created. To create a new Virtual Variable click the “New Virtual Variable” button.

Win7pic1

This is the interface used to create Virtual Variables. Any combination of the variables, operators and constants can be used to create the Virtual Variable. There are two methods that can be used to create Virtual Varibles, General and Advanced.

Using the General method users use buttons to enter the equation.
For Example: To convert Air Temperature from celsius to farenheit for “Demo Weather Station” site you first select the Air Temperature variable and click “Add Variable” (or double click the varible) then click the “*” button, next click the “(” button followed by 9/5 and finally click the “)” button, finish by clicking “+” and 32.

Win7pic1

Advanced

Using the Advanced method users can enter the equation by using the keyboard. This method is more flexible and allows users to copy and reuse the equation.
For Example: To convert Air Temperature from celsius to farenheit for “Demo Weather Station” site you first double click Air Temperature variable (it is also possible to enter the Variable ID manually) and then type *(9/5)+32. A list of variables that have been added to the equation is shown below. Notice that you can place the pointer at any place in the equation and then double click a variable and it will be inserted at that position.

Win7pic1

You need to give the Virtual Variable a name, here we have entered the name “Air Temp F°” and selected the °F temperature Unit. Next you need to select which Site the Virtual Variable belongs to, the new virtual variable will appear as any other variable belonging to the Site you select.

Win7pic1

When you have finished creating the equation for the Virtual Variable you should test the Variable by clicking the “Test” button.

If the equation has a syntax error the following message will appear.

Win7pic1

If the equation has no syntax error then you can test your Virtual Variable. You can also use the test feature to confirm that the equation you have entered is correct.

Win7pic1

If the equation has no syntax error then you can test your Virtual Variable. You can also use the test feature to confirm that the equation you have entered is correct.

Win7pic1

You can change the Value after the Variable name and click “Recalculate” to see the Result your Virtual Variable produces.

Win7pic1

After you have tested your Virtual Variable click “Create Virtual Variable“.

When you have created a Virtual Variable it will appear in the Variable list.

To use the newly created virtual variable select Page Setup and there add the new virtual variable to one of the existing graphs or create a new graph for the virtual variable. Virtual Variables appear with a filled diamond in front of their name.

Win7pic1

 Function list

The available operators for Virtual Variable are:

  • + Addition operator
  • - Minus operator
  • * Multiplication operator
  • / Division operator
  • () Parenthesis
  • ^ Returns the value of X raised to the power of Y (X^Y).
  • % Modulo operation. Returns the remainder of N divided by M.
  • abs Return the absolute value
  • round Round the argument. Possible to use Decimal Places Round round(X,D). Only available in Advanced Equation tab.
  • floor Return the largest integer value not greater than the argument
  • ceil Return the smallest integer value not less than the argument
  • cos Return the cosine. Result is in Radians.
  • sin Return the sine of the argument. Result is in Radians.
  • tan Return the tangent of the argument. Result is in Radians.
  • acos Return the arc cosine. Result is in Radians.
  • asin Return the arc sine. Result is in Radians.
  • atan Return the arc tangent. Result is in Radians.
  • cot Return the cotangent
  • rad Return argument converted to radians
  • deg Convert radians to degrees
  • ln Return the natural logarithm of the argument
  • log2 Return the base-2 logarithm of the argument
  • log10 Return the base-10 logarithm of the argument
  • exp Returns the value of e (the base of natural logarithms) raised to the power of X.
  • sqrt Return the square root of the argument

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.2.2 Rate of Change


Introduction: Rate of Change is used to calculate how fast a sensor value is changing. This might be useful in order to indicate a flood or a landslide or any sudden movement that is otherwise hard to detect. RoC for a sensor value may be plotted just like the sensor value itself.

Sometimes it is of interest to plot both a sensor value and its RoC which gives clear picture of how RoC behaves. In order to plot both the sensor value and its RoC value you need to create a virtual variable of the sensor value and then choose to plot one of the two as normal trend line and the other as RoC.

Further: Rate of Change (RoC) is used to calculate the difference between the current sensor value and the sensor value X Time Interval (seconds, minutes, hours or days) ago. RoC may be calculated both for a single variable and a virtual variable.

When choosing to use RoC of a variable then click the Rate of Change Active checkbox and then select Precision which is number of decimals to show.

Win7pic1

The Equation for RoC calculations is as follows:

Win7pic2

The RoC Time Interval can be in Minutes, Hours or Days; RoC is calculated for this Time Interval.

To set the RoC for a specific Time Interval keep the Time Unit the same as Time Interval, see next paragraph.

RoC Time Unit can be in Seconds, Minutes, Hours or Days. The RoC Time Unit allows you to plot the average difference for specific time unit for the RoC. For Example if calculating RoC for 24 hr and have RoC Time Unit set to 1hr that you will be plotting average difference per hour for those 24 hours. In other words, dividing the whole difference with 24 so you have the change per hour. See equation below.

Win7pic2

If we have the same example but have the Roc Time Unit set to 12 hours.

Win7pic2

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.2.3 Edit Virtual Variables


To edit a Virtual Variable select the variable you wish to edit by first selecting the Site the variable belongs from the Site list and then selecting the variable from the Virtual Variable list.

Make the necessary changes to the Virtual Variable’s Name, Unit, Site, Equation and the click the Save Virtual Variable button.

Read the New Virtual Variable chapter above for further information.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.2.4 Delete Virtual Variables


NOTE: This feature is available on the web interface in Enterprise version.

Win7pic1

Select the Virtual Variable you wish to delete and click the Delete Virtual Variable button.

The following message will appear:

Win7pic1

Click Yes to delete the Virtual Variable.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.2.5 Duplicate Virtual Variables


If there are many Virtual Variables that are similar it can be a great time saver to use the Dublicate Virtual Variable function.
For an example, dublication would work well for creation of new Virtual Variable with a complex equation and many constant based on a previously created Virtual Variable implementing the same complex equation.

To Duplicate a Virtual Variable click “Duplicate Virtual Variable” button.

Win7pic1

Select a new name for the Duplicated Virtual Variable.

Win7pic1

The new Virtual Variable shows in the list.

Win7pic1

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.2.6 Export Virtual Variables


It is an option to export all Virtual Variable configurations from VDV in order to have an overview of the Virtual Variables in use as well as to have a template for importing new or modified Virtual Variable into VDV.

Go to Edit -> Virtual Variable in db.data.browser.

Click Export Virtual Variable Configuration to File and select where to save the .CSV file.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.2.7 Create VV CSV File


Before creating a VV .CSV file it is important to have a template for this file. Export the Virtual Variable List to get this template (Go to Edit -> Virtual Variable, Click Export Virtual Variable Configuration to File in db.data.browser.

To start from scratch delete all the lines (but not the first Row) unless needed to change some Virtual Variable settings.

Below is a guide what each column may contain:

Station: This Column is not imported and may be empty. Station is the Site Name which the VV belongs to.

Station_ID: The station ID can be found in Site Export List. This is done in db.robot.c under File menu -> Export Site List. This Column can only contain integer.

Variable: This is the name for the Virtual Variable which will be created in Vista Data Vision.

Variable_ID: If modifying a VV that already exists then it is important to use its Variable_ID. The Variable_ID can be found in the Site Export list.
NOTE: If creating a new VV leave this column empty and VDV will give this VV a new Varible_ID.

Unit: This column is not imported and may be empty.

Unit ID: Important is to select a Unit for the Variable. Select correct Unit ID from the Unit List exported before. To Export that list go to Edit-> Edit Unit and Click Export Unit List in db.robot.c

Formula: All Functions available in VDV are allowed in the Formula (see here below). Variables in the Formula need to be inside a $$ tags.

Example for Converting Celsius to Fahrenheit
$222$*9/5+32

RoC Active: This can either be 0 or 1.

0 means that RoC is not Active

1 means that RoC is Active.

RoC Precision: The amount of numbers behind the decimal point, this is an integer.

RoC Period Value: Value for RoC Time Interval, this is an integer.

RoC Period Type: This value is in seconds. The options here are Minutes/hours/days.

In this column only the following options are allowed:
60 = Minutes
3600 = Hours
86400 = days

RoC Unit Value: Value for RoC Time Unit, this is an integer.

RoC Unit Type: This value is in seconds. The options here are Seconds/minutes/hours/days.

In this column only the following options are allowed:
1 = Seconds
60 = Minutes
3600 = Hours
86400 = days

RoC Example: Calculate RoC for 24 hours and Plot average change per hour for those 24 hours. Set RoC Period Value= 24, RoC Period Type= 3600 (for hour), RoC Unit Value=1 and RoC Unit Type=3600 (for hour).

Datum Variable ID: Select a Variable ID to use as a Datum reading in the formula.

Datum Timestamp: Timestamp of the reading that should be used as Datum. Example “2013-06-18 14:20:00″

Datum Information: Information about the Datum reading that can be viewed online.

Constants: Create constants to use the the equation. Using constants can make the equation easier to read and manage if it is complicated. Example “Constant1=10|Constant2=20″

Example of Virtual Variable(VV) that has been exported. Modify the equation and import it again to update the same VV. To create a new Virtual Variable then keep the Variable ID column empty.

Station;Station ID;Variable;Variable ID;Unit;Unit ID;Formula;RoC Active;RoC Precision;RoC Period Value;RoC Period Type;RoC Unit Value;RoC Unit Type;Datum Variable ID;Datum Timestamp;Datum Information;Constants
“WindSensors”;21;”Export123″;1905;”kW”;19;”$617$+Constant1+Constant1″;0;0;1;3600;1;3600;620;”2013-06-18 14:20:00″;”Datum info”;”Constant1=10|Constant2=20″
Functions available
+ Addition operator
– Minus operator
* Times operator
/ Division operator
() Parenthesis
^ Returns the value of X raised to the power of Y (X^Y).
% Modulo operation. Returns the remainder of N divided by M
abs Return the absolute value
round(X,D) Rounds the argument X to D decimal places.
D defaults to 0 if not specified. D can be negative to cause D digits left of the decimal point of the value X to become zero.
floor Return the largest integer value not greater than the argument
ceil Return the smallest integer value not less than the argument
cos Returns the cosine of X, where X is given in radians
sin Return the sine of X, where X is given in radians
tan Return the tangent of X, where X is given in radians
acos Return the arc cosine
asin Return the arc sine
atan Return the arc tangent
cot Return the cotangent
rad Return argument converted to radians
deg Convert radians to degrees
ln Return the natural logarithm of the argument
log2 Return the base-2 logarithm of the argument
log10 Return the base-10 logarithm of the argument
exp Returns the value of e (the base of natural logarithms) raised to the power of X.
sqrt Return the square root of the argument

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.2.8 Import Virtual Variables


To quickly create multiple Virtual Variables use Excel, store the result as a .CSV file, and Import into VDV.

Go to Edit -> Virtual Variable in db.data.browser.

Click Import Virtual Variable Configuration

Click Select Virtual Variable File in the bottom-left corner and locate the Virtual Variable .CSV File. For the format of the VV File take a look at how to create one. How to Create a VV CSV File.

Here is an overview of the Virtual Variables to be imported into VDV. Check and make sure everything is okay. If needed, click Remove Line to remove any unwanted Virtual Variables.

Finally Click Import Settings.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.3 Alarm Limits on Graph


Simple is to display the Alarm Limit for Variables. The Alarm Limits are shown as horizontal lines on the graph, lowlow & highhigh are red and low&high are yellow. Only one variable on the graph can have this option selected.

In Graph Setup, check the Show Alarm Limit in the Variable Setup tab.

Win7pic1

After the alarms limits have been set they will show up on the graph like on the following picture.

useful-alarmlimits

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.4 Contacts


In Vista Data Vision you can create Contacts and group them into Contact Groups. You use these Contact Groups when configuring the Alarms and Reports. VDV will send Alarm Notification and Reports to the Contacts.

Win7pic1

Contact Setup allows the operator to create contact groups to receive alarm messages. Each Contact may be associated with one or any number of Contact Groups. Alarms are sent as emails, or as SMS messages. Note that emails may be sent directly to the newer types of Cellular Phones as SMS.
NOTE: Only use the Contact’s Cellphone number if SMS alarm messages are actually to be sent from a Cell Modem connected to the PC’s COM port.

NOTE: This feature is only available in the Pro and Enterprise version of db.robot.c.
Contacts are used when sending Alarms or when sending Reports and apply to the Alarm and Report Toolkits.

To manage your contacts choose the Contact Setup command from the Edit menu.

NOTE: You may need only one contact group with a single name configured as a recipient of alarm messages. But you have the option of configuring any number of contact groups in a complex way in order to tailor-make an alarm messaging system for the most demanding situation.

Win7pic1

Here it is possible to control every aspect off the Contact Setup.

To create a new Contact press the New Contact button.

Win7pic1

Enter a Contact Name, Email, and Company for the Contact. The Email is the most common route for Alarm Messages. However, if a Cell Modem is actually connected to the COM port of the PC running VDV, and is actually working, then SMS may be sent directly from that Cell Modem directly to a Contact’s Cellphone.
Most commonly no Cell Modem is connected to the PC running VDV and therefore there is no need to insert the Contact’s Cellphone number. If Cell Modem is connected please refer to the Cell Modem Setup chapter below.

To Edit a Contact first select the Contact to edit from the contact list, then press the Edit Contact button. Make changes to the Contact Name, Email, Cell phone or Company and press Save when done.

To Delete a Contact first select the Contact to delete from the contact list, then press the Delete Contact button. Press the Yes button in the dialog box that appears next to confirm.

To create a new Contact Group press the New Group button.

Win7pic1

Enter a Contact Group Name and Description, press Save when done.

To Edit a Contact Group first select the Contact Group to edit from the contact group list, then press the Edit Group button. Make changes to the Contact Group Name or Description and press Save when done.

To Delete a Contact Group first select the Contact Group to edit from the contact group list, then press the Delete Group button. Press the Yes button in the dialog box that appears next to confirm.

When Contacts and Contact Groups have been created we assign Contacts to Contact Groups. A Contact can be a member of more then one Contact Group.
To assign Contacts to Contact Groups first select the Contact Group to assign Contacts to from the Contact Group list, then press the Edit Contact Group Members button.

Win7pic1

To add a Contact to the Contact Group first select the Contact from the Contacts list, then press the >> button. To remove a Contact from the Contact Group press the << button.

For each Contact you can adjust the following:

  • Active: If the contact is not active then he will not receive any alarm messages.
  • Notification: The contact can receive his alarm messages as an email, SMS or both.
  • Shift: You can choose which shifts the contact should be assigned to. A contact can be assigned a single shift or all shifts.

Also for the Contact Group the following can be configured:
Confirmation message when shift starts and ends: You can send a message to each contact when his shift starts and ends, keeping him informed about his shift status.
To send a customized message press the Shift Starts Text button to enter a new text to be sent out to members of this Contact Group when their shift starts, press the Shift Ends Text button to enter a new text to be sent out to members of this Contact Group when their shift ends.

Reminder message: You can send a reminder message once a day at a specific hour to those contacts that are on the active shift, both as a reminder to those contacts and also as a way to make sure the monitoring system is functioning.
To change the hour of the reminder message, select a new value from the drop down list.
To send a customized message press the Reminder Text button to enter a new text to be sent out

Shifts
To edit the Shift setup for the selected Contact Group, press the Edit Contact Group Shifts button.

Win7pic1

Each Contact Group can have 4 different Shifts if needed. By default a Contact Group only has a single shift called Week. The Week shift is a shift covering the entire week. When creating new shifts it is important to remember that the shifts have to cover the entire week. For example to change the Shift setup and have two shifts, one covering the weekdays and the other covering the weekend we would need to make Shift 2 active by pressing the Active check box associated with Shift 2. Next we make Saturday and Sunday active and change the To hour to 24. Finally we make Saturday and Sunday inactive for Shift 1.

Win7pic1

When finished editing the Shift setup press the Save button. If the Shifts do not cover the entire week or they overlap then an error messages appears.

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.5 Customize Layout


This feature is only for Professional License and above. If you are running a Trial Version and would like to try out the Professional or Enterprise version please contact us for an Evaluation License.

With Vista Data Vision it is simple to customize the layout. You can change the login page and add your text and header. Once logged in you can change the Logo that appears in the top-left corner to your company logo.

Login Page Setup
——————————————————————————–
NOTE: This feature is only available in the Pro and Enterprise version of db.web.browser.

Login Page of the VDV web service should represent the VDV operator and is the front end to all data. Therefore, it may be important to the VDV operator to customize the Login Page to reflect his company and service, and to give message to his clients. The Login Page Setup is an editor that will allow easy editing of the Login Page without any programming.

——————————————————————————–

The Login Page Editor is a simple tool to make simple modifications on the VDV Web Login Page. The Image can be changed as well as the text and color scheme of the page.

Win7pic1

Login Page Tab

Shows how the Login Page looks like. To edit the Login Page select the Configure tab

Win7pic1

The Login Page Tab, displays the Login Page

Configure Tab

First time the Configure tab is opened it displays the defaul Login Page settngs. Here some simple changes can be made to the Login Page. The Image can be changed and the page text and color scheme can be changed. If some modifications have been made to the page they can be viewed by selecting the Login Page tab. To change back to the default page click on the Set to Default Values and Use Defaul Logo buttons.

Win7pic1

The Configure Tab, for changing the image, text and color scheme can be changed

Changing the Logo: Click the Folder icon after the Select New Logo input field and browse to where the image is located. Select the image and click Select. This image will be displayed at the top of the page.

The Default Logo is 580 pixels wide and 120 pixels high.

NOTE: Only jpeg, jpg, gif and png image formats are supported.

Changing the text: Possible is to change the text on the Login Page. Simply write a new text into the Input field for each text string. Change or Add text into the Description box. Possible is to use HTML code.

Changing the color: The Background color of the Login Page and Description Box can be modified. To change the color click the appropriate color box. A color pallet will be displayed, new color is chosen and it changes right away.

Move the mouse over a color box and click it, then a color pallet will be displayed

View our changes be clicking the Login Page tab.

Win7pic1

When all the changes are made, click Save in the bottom right corner. Open a browser to where the VDV is located and press the Refresh button or F5.

Push the “Cancel” button to close the Login Page Editor.

NOTE: The login page can be modified at will. However according to the Vista Data Vision license agreement the following two lines of text must always be present on the login web page.

Copyright © 2004-2012 Vista Engineering. All Rights Reserved.
www.vistadatavision.com

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.6 Different Languages


The Language of Vista Data Vision web site can be changed from English into any other Language. Built in Languages are Spanish, German and English. Simple is to add a New Language and translate the web page to a other language..

In the Professional Version you can select which language each User has.

In the Professional Version you can select which language each User has.

Open db.web.browser » Web Site Setup » Languages

db.web.browser Help File » Language

useful-language

 

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

05.7 Real Time Display


This feature is only for Professional License and above. If you are running a Trial Version and would like to try out the Professional or Enterprise Version please contact us for an Evaluation License.

Real Time Display (RTD) is used to give users a clear overview of all data on a single page or multilevel pages. Latest data can be viewed on numerical indicators and as trend lines on graphs. Furthermore, Alarm Status and Data Update Monitoring of each variable may be indicated by background color.

Take a look at this video to see how it works. (This video is form earlier version but it shows the basic functions well)

db.web.browser Help File » Real Time Display

Was this helpful? Thank you for your feedback, it's always welcome.Thank you for your feedback, we will consider improving this content.

Contact us

Send us your question and we will get back to you shortly.

Questions, issues or concerns? I'd love to help you!

Click ENTER to chat